Google Site Search


Wednesday, April 9, 2014

JBoss CommunityProjects (including WildFlyAs): OpenSSL HeartBleed Vulnerability

I want to take this post to summarize that "JBoss community projects including WildFly Application Server are not directly affected by the OpenSSL HeartBleed Vulnerability".

JBossWeb APR

JBossWeb APR functionality requires OpenSSL 0.9.7 or 0.9.8 which is not affected by this vulnerability.

I have consulted the Red Hat Security Response Team before posting this note. We continue to monitor the situation.
Feel free to report any anomalies using

We do recommend taking the appropriate precautions.

Please use the links in the references section for gauging indirect exposure to the HeartBleed vulnerability.

Indirect exposure may be possible:
  • Maybe you have a web server in front of JBoss/WildFly Application Server that may be affected.
  • Maybe your operating system on which the JBoss community projects are running may be affected.
  • Maybe you have OpenSSL v1.0.1 used by your application infrastructure. 


Please refer to the following articles for more information:

Official OpenSSL Official Advisory:
HeartBleed Information:

Red Hat Official Announcement:


Amazon Web Services Advisory:

Official Linux Distribution Pages 

No comments: